Back to overview
Maintenance

Update firmware

Nov 11 at 10:37am CET  –  Nov 13 at 10:37am CET
Affected services
Storage server

Resolved
Nov 11 at 10:37am CET

Maintenance on all Storage Shares and software upgrade to version 31.0.10